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Objective: To build a three-dimensional (3-D) simulation model of an Integrated Circuit (IC) chip,
and run Heat Transfer simulations using surface and volumetric heat sources, in order to study
localized heating inside the chip.
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Figure 1. 3D model of the IC chip simulated in this tutorial. Top Figure shows a vertical crosssection through the chip. The vertical dimension has been magnified for better visualization. The
bottom Figure the field oxide and passivation layers have been removed to show the
interconnects (Metal 1 and 2) clearly.
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In this tutorial, we will:
•

build a 3D simulation model of an IC chip and automatically generate a computational
mesh for it using CFD-Micromesh,

•

set the simulation parameters for the Heat Transfer (Heat) module of CFD-ACE+, and
run steady-state simulations

•

post-process the results using CFD-VIEW to obtain various temperature and heat flux
distributions, plots, color contours, cut-planes etc

Brief Description of the Problem
Heat is generated inside an IC chip by active electrical devices. In order to electrically insulate
different devices, a dielectric medium (usually silicon dioxide) is used inside the chip. However,
silicon dioxide is also a poor thermal conductor, and the heat generated by active devices does
not have an efficient path to be carried out. This leads to “localized heat trapping” inside the chip.
Since material and electrical properties of semiconductors are temperature dependent, the
trapped heat leads to poorer electrical performance of the particular device. If the devices are
densely packed inside the chip, this localized heating can affect neighboring devices as well, and
adversely affect the electrical behavior of the overall chip.
In this tutorial, we build a 3D model of an IC chip assuming that the manufacturing process is
similar to a generic Silicon On Insulator (SOI) process. The buried oxide layer in Figure 1 acts as
the insulator over which the thin silicon device layer is present. In the traditional manufacturing
process, the buried oxide layer is absent, and the active silicon devices are present as part of the
bulk silicon layer.
The heat sink at the bottom is not present in the final simulation model. It is shown in Figure 1 to
better illustrate the overall chip structure. In the present simulation, the interface between the bulk
silicon and the heat sink is used as a constant temperature boundary condition (T=300 K =>
infinite heat sink). The active devices are assumed to be thin “slices” of silicon as shown in Figure
1. The heat sources are applied either in the entire silicon device volume (volumetric source) or at
the upper surface of the silicon devices (surface source), simulating the fact that most of the heat
generation occurs in the channel region of transistors. All contacts, vias and metal interconnects
are assumed to be copper. The buried oxide and field oxide are both silicon dioxide. The
passivation layer at the top of the chip is also assumed to be silicon dioxide.
For Heat Transfer simulations, the following material properties of all constituent materials are
required:
•

Density

•

Specific Heat

•

Thermal Conductivity
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In the following tutorial these definitions apply:
LB = Left mouse button, MB = Middle mouse button, RB = Right mouse button

3D Model Generation and Meshing using CFD-Micromesh
Structures can be built in CFD-Micromesh in two ways – importing layouts already generated by
an external layout editor (e.g. CIF or GDSII files), or creating the structure manually. Importing
layouts is the better option when the structure is a complicated IC layout with several devices and
multiple layers. But if we are interested in building a single device (e.g. transistor or diode), then
creating it manually may be more convenient. Both these steps are described in the following
sections, though for this Tutorial the structure will be built manually.

Importing layouts generated in an external layout editor
1. Start a new project in CFD-Micromesh, by selecting from the top menu: File -> New
2. Currently the following layout formats are supported: CIF, GDSII and DXF (optional). Click
Import ->CIF file (or GDSII file as the case may be) from the top menu. A new window opens
up asking if you want to use a “technology file”. Click No.
3. A file browsing window appears. Select the layout file to be imported.
4. The layout from the CIF or GDSII file appears in the viewing window. On the right side, a list
of layers present in the layout can also be seen. However, the layers in this list do not have
their physical names. They have coded layer names (in CIF) or layer numbers (in GDSII). In
order to convert these coded names to their physical names, we need to add additional
technology information.
5. Convert CIF layer names or GDSII layer numbers into physical layer names, using the
process technology information
•

Select (by clicking LB) the first layer at the bottom of the list.

•

Click RB on the selected layer name
The “Layer Properties” dialog window opens.

•

Select the Edit Material button - the “Materials” dialog window opens

•

Change the CIF “material” names or GDSII layer numbers into new (physical) names, by
clicking on Rename button in the "Materials" window, and entering the new layer names.

•

Click Close in the "Materials" window.

•

Click Accept in the "Layer Properties" window.

If you want to see the actual mapping between CIF (or GDSII) layers and CFD-Micromesh layers
and operations, that is, the full Technology Conversion Table for currently active Micromesh
project file, select from the menu: Import -> Tech. Conv. Table...
6. Click Import -> Save Technology from the top menu. A Save Technology window opens up.
Save the technology file (i.e. the layer name conversion chart created in the previous step).
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This technology file can be used later to import other CIF or GDSII files associated with the same
technology process. In such a case, click Yes in response to whether you want to use a
Technology File, and select the saved Technology File.
7. Once the layout has been imported and physical layer names assigned, we need to define
the vertical dimensions of each layer. The process of assigning the vertical dimensions is the
same whether we import layouts or build the structure manually, and is described as part of
the next section.

Building a new structure manually
Start a new project in CFD-Micromesh, by selecting from the top menu: File -> New
8. Setting dimensions and resolutions of your model.
•

Click LB on the Change Boundary button [

] in the top toolbar.

A "Dimensions and Resolutions" window appears, as below:

The layout dimensions Min.[m] and Max.[m] are initially displayed in meters, which may
not be convenient in some projects (e.g. microelectronics).
•

In such a case, close this window (click Cancel)

•

Change the units for displaying the project, by clicking in the top menu: View ->
Display Units. In the “Display Unit” window (see below) you may choose the unit
appropriate for your project.

•

For our project in this tutorial, let us choose micrometer as the unit, and then click
Accept.
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•

Re-open the "Dimensions and Resolutions" window by clicking the Change Boundary
button [

] in the top toolbar. Now type the size of the project, as in the figure below,

with dimensions in micrometers.

Note that you have set the three-dimensional resolution (Voxel Size [um]) of your model
in the above window. The resolution is expressed in voxels, or three-dimensional blocks,
analogous to two-dimensional pixels in 2D images. The Voxel Size numbers in this
window express the size of each voxel for the three dimensions.
NOTE: The voxels must be small enough to enable viewing of the smallest feature
desired. The 3D model visualization (ray tracing) procedure in CFD-Micromesh is based
on the assumption of cubic voxels. Hence, if their shapes are far from cubic, the viewed
proportions of the generated 3D solids will be deformed. However, this does not affect
the final model and the computational mesh (DTF file) for the CFD-ACE+ simulation, but
only affects the 3D viewing by ray tracing in CFD-Micromesh (“3D Photo”).
Decreasing voxel size will result in better accuracy and rendering of shapes of the
generated 3D model, but will also increase generation time and the size of intermediate
disk files, and at some limits the program may run out of RAM capacity. The minimum
voxel size limit depends on the computer configuration (in particular available memory
volume). The general rule is: if the model building takes more than 15 minutes (with 700
MHz Pentium or equivalent), the RAM capacity has probably been exceeded and the
program is forced to use disk file swapping, which extends the calculation time
dramatically. In such a case, stop the current calculation (3D solids generation) by
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clicking on "Stop Computation" button [
] located on the toolbar, re-open the
"Dimensions and Resolutions" window (Tools -> Change Boundary), and increase the
voxel size proportionally in each direction.
9. Setting "Snap to Grid" parameters
Click LB on Change Grid button [

] in the top toolbar. A "Grid" window appears, as below:

Change the Grid step to 2.5 (micrometers), and click Accept.
The grid can be turned on and off by means of the Show Grid [
or by checking and un-checking the button in the figure above.

] button in the top toolbar,

10. Creating a layout of the design:
•

Click LB on the New Layer button [

] in the top toolbar, to create a new layer.

On the right-hand side, you should see a new layer with the name "NEW: AIR (deposit)".
At that point, the only existing “material” is “Air” in the empty space of the project area,
defined in the previous section.
Click RB on the NEW: AIR (deposit) layer.
In the "Layer Properties" windows that appears, click Edit Material button.
Since we want to create several new layers with different names, click Add
button in the "Materials" window.
In the "New Material" window, type the name of the new layers to be added, for
example, Name: “Sink", for the Heat Sink at the bottom, and click Accept.
Click Add again, type Name: “BulkSi”, for the bulk silicon substrate, and click
Accept.
In the same manner create names for other layers: BOx (Buried Oxide), FOx
(Field Oxide), DevSi (Silicon Device), Contact, Via, Met1 (Metal 1), Met2 (Metal
2) and Pass (Passivation).
IMPORTANT: For the Sink layer name above, UNCHECK the Mesh It box in the “Edit
Material” window. This will ensure that the mesh is not generated in the Heat Sink and
the heat transfer equations are not solved in these regions (recall that the BulkSi – Sink
interface is assumed to be an infinite sink; an isothermal condition of T=300K will be
applied there)
Click Close in the "Materials" window.
•

Back in the "Layer Properties" window of the first created layer:
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In the Material: pull-down list, change the name from AIR to Sink.
Change Thickness [um] to 1
Ensure that norm n is 0, norm beta is 1 and all other parameters have default
values
Click Accept.
•

Create the Sink block in your model.
Draw a layout (top view) of the Sink layer, by selecting the New Rectangle
button [ ] from the toolbar.
While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw a rectangle with coordinates (0um,
0um) to (100um, 100um).
To check if your Sink layout has the correct dimensions, click RB on the red
(highlighted) rectangle that you have just drawn. In the “Rectangle Properties”
window check if position and dimensions of your rectangle are appropriate. If not,
correct them by typing the accurate number (Pos.X = 0, Pos.Y = 0, Size X = 100,
Size Y = 100), and click Accept.

•

Create new layer for BulkSi, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a second layer with the name
"NEW: Sink (deposit)" (creating a new layer makes a copy of the currently active layer
with all its properties).
In the list of layers, click RB on the NEW: Sink (deposit) layer, and in the "Layer
Properties" window:
Change the name from Sink to BulkSi in the Material: pull-down list
Set Thickness [um] to 0.5
Click Accept.
•

Create the Bulk-Si block in your model.
Draw the layout of Bulk-Si by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw a rectangle with coordinates (12.5um,
12.5um) to (87.5um, 87.5um).
To check if your Bulk-Si layout has the correct dimensions, click RB on the red
(highlighted) rectangle that you have just drawn. In the “Rectangle Properties”
window check if position and dimensions of your rectangle are correct: Pos.X =
12.5, Pos.Y = 12.5, Size X = 75, Size Y = 75. If they are not correct, type the
appropriate numbers, and click Accept.
•

Create new layer for BOx, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: BulkSi (deposit)".
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Click RB on the NEW: BulkSi (deposit) layer, and in the "Layer Properties"
window:
Change the name from BulkSi to BOx in the Material: pull-down list
Set Thickness [um] to 0.2
Click Accept.
•

Create the BOx block in your model.
Draw the layout of BOx, by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw a rectangle with coordinates (12.5um,
12.5um) to (87.5um, 87.5um), i.e. exactly on top of the Bulk-Si layer created
earlier.
To check if your BOx layout has the correct dimensions, click RB on the red
(highlighted) rectangle that you have just drawn. In the “Rectangle Properties”
window check if position and dimensions of your rectangle are correct: Pos.X =
12.5, Pos.Y = 12.5, Size X = 75, Size Y = 75. If they are not correct, type the
appropriate numbers, and click Accept.
•

Create new layer for FOx, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: BOx (deposit)".
Click RB on the NEW: BOx (deposit) layer, and in the "Layer Properties"
window:
Change the name from BOx to FOx in the Material: pull-down list
Change the operation type from Deposit to Insert in the Operation pull-down list
Set the Position [um] to 1.7 and set Thickness [um] to 3.1
Click Accept.
•

Create the FOx region in your model.
Draw the layout of FOx, by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw a rectangle with coordinates (12.5um,
12.5um) to (87.5um, 87.5um).
To check if your FOx layout has the correct dimensions, click RB on the red
(highlighted) rectangle that you have just drawn. In the “Rectangle Properties”
window check if position and dimensions of your rectangle are correct: Pos.X =
12.5, Pos.Y = 12.5, Size X = 75, Size Y = 75. If they are not correct, type the
appropriate numbers, and click Accept.
NOTE: The field oxide surrounds all the silicon devices, Metal1 and Metal2 layers.
Therefore, we create the field oxide layer first, and then insert the different internal
components such as the silicon device layer, Metal1 and Metal2. Also, the Insert
operation works better than Deposit when several embedded objects are present.
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•

Create a new layer for DevSi, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: FOx (insert)".
In the list of layers, click RB on the NEW: FOx (insert) layer, and in the "Layer
Properties" window:
Change the name from FOx to DevSi in the Material: pull-down list
Set Position [um] to 1.7
Set Thickness [um] to 0.05
Click Accept.
•

Create the DevSi blocks in your model.
Draw the layout of DevSi by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw 3 rectangles with coordinates:
(20um, 60um) to (40um, 80um);
(60um, 40um) to (80um, 60um); and
(20um,20um) to (40um,40um)
To check if your DevSi layouts have the correct dimensions, click RB on the red
(highlighted) rectangles that you have just drawn. In the “Rectangle Properties”
window check if position and dimensions of your rectangles are correct.
•

Create new layer for Contact, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: DevSi (insert)".
In the list of layers, click RB on the NEW: DevSi (insert) layer, and in the "Layer
Properties" window:
Change the name from DevSi to Contact in the Material: pull-down list
Set Position [um] to 1.75
Set Thickness [um] to 0.75 um
Click Accept.
•

Create the Contact blocks in your model.
Draw the layout of Contact by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw 6 small rectangles with coordinates:
(25um, 35um) to (27.5um, 37.5um);
(32.5um, 35um) to (35um, 37.5um);
(25um, 62.5um) to (27.5um, 65um);
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(32.5um, 62.5um) to (35um, 65um);
(62.5um, 45um) to (65um, 47.5um);
(62.5um, 52.5um) to (65um, 55um)
•

Create new layer for Met1, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: Contact (insert)".
In the list of layers, click RB on the NEW: Contact (insert) layer, and in the
"Layer Properties" window:
Change the name from Via to Met1 in the Material: pull-down list
Set Position [um] to 2.5
Set Thickness [um] to 0.65 um
Click Accept
•

Create the Met1 blocks in your model.
Draw the layout of Met1 by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw 5 rectangles with coordinates:
(25um,35um) to (27.5um,65um);
(32.5um,35um) to (65um,37.5um);
(62.5um,35um) to (65um,47.5um);
(32.5um,62.5um) to (65um,65um);
(62.5um,52.5um) to (65um,65um)
•

Create new layer for Via, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: Met1 (insert)".
In the list of layers, click RB on the NEW: Met1 (insert) layer, and in the "Layer
Properties" window:
Change the name from Met1 to Via in the Material: pull-down list
Set Position [um] to 3.15
Set Thickness [um] to 1 um
Click Accept
•

Create the Via blocks in your model.
Draw the layout of Via by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw 3 rectangles with the coordinates:
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(25um, 35um) to (27.5um, 37.5um);
(32.5um, 62.5um) to (35um, 65um);
(62.5um, 45um) to (65um, 47.5um)
•

Create new layer for Met2, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: Via (insert)".
In the list of layers, click RB on the NEW: Via (insert) layer, and in the "Layer
Properties" window:
Change the name from Via to Met2 in the Material: pull-down list
Set Position [um] to 4.15
Set Thickness [um] to 0.65 um
Click Accept
•

Create the Met2 blocks in your model.
Draw the layout of Met1 by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw 3 rectangles with coordinates:
(22.5um,27.5um) to (30um,45um);
(30um,55um) to (37.5um,72.5um);
(55um,42.5um) to (72.5um,50um)
•

Create new layer for Pass, by clicking LB on New Layer button [

] in the top toolbar.

In the list of layers on the right-hand side, you should see a new layer with the name
"NEW: Met2 (insert)".
In the list of layers, click RB on the NEW: Met2 (insert) layer, and in the "Layer
Properties" window:
Change the name from Met2 to Pass in the Material: pull-down list
Set Position [um] to 4.8
Set Thickness [um] to 1
Click Accept
•

Create the Pass region in your model.
Draw the layout of Pass, by selecting the New Rectangle button [
toolbar.

] from the

While holding left mouse button down and observing the current cursor
coordinates in the lower-right corner, draw a rectangle with coordinates (12.5um,
12.5um) to (87.5um, 87.5um).
To check if your Pass layout has the correct dimensions, click RB on the red
(highlighted) rectangle that you have just drawn. In the “Rectangle Properties”
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window check if position and dimensions of your rectangle are correct: Pos.X =
12.5, Pos.Y = 12.5, Size X = 75, Size Y = 75. If they are not correct, type the
appropriate numbers, and click Accept.

NOTE: Different layers in CFD-Micromesh should preferably have different colors. This
enables easier viewing of the layers while they are being added in the Micromesh
Project, and also in the Solid View models generated later. Micromesh provides different
colors for the first few layers. To change the color of a layer that has a similar color as
another layer:
click LB to select the layer name
click RB to open the “Layer Properties” window
click Edit Material -> Color, and select the color of your choice
click Accept, close the “Materials” window and click Accept in the “Layer
Properties” window.
Save the Project file.
•

Save your project, by selecting Save As… from File menu (File -> Save As…)
For example, you may save it under the name heatchip.ump.
Projects in CFD-Micromesh are saved to the disk in a special format, containing all model
data as well as setup parameters for the 3D model and mesh generation for the current
project. All these data are saved to a binary file with the extension .ump (for µMesh
Project). Initially, a new project is given a name untitled1.ump, to be changed by user
during the first saving of the project to disk.
IMPORTANT: Before you save files into your working directory, make sure that you can
view the complete file extensions. From past experience, this is observed to be a source
of confusion/errors!

11. Generating and viewing a 3D solid model
•

There are three methods of generating and viewing a 3D model in CFD-Micromesh:
3D Quick View – Very fast building of a 3D model from planar elements of
defined position and thickness, and viewing the 3D model with zooming and
rotation. This option is limited to layouts including rectangular shapes only.
Typical model building time: 1-2 seconds (700 MHz Pentium PC).
3D Solid View – Generating a solid model by geometrical deposition/etching
simulation, using voxel (volumetric pixel) technology – this technique allows to
generate models of arbitrary shapes, including rounded and oblique side-walls,
non-planar conformal layers, etc. Viewing the 3D model allows for zooming and
rotation. Typical model building time: 1-5 minutes (700 MHz Pentium PC).
3D Photo - Generating a solid model by geometrical deposition/etching
simulation, using voxel technology (the same as in method 2) – this technique
allows to generate models of arbitrary shapes, like rounded side walls, nonplanar layers, etc. Visualization procedure uses the ray tracing technique that
produces up to four different static views (stored as GIF files) of the generated
3D model. Though these are only static snapshots of the 3D model, thanks to ray
tracing, they give the highest quality of rendering, with controlled light, shadows,
reflections, and anti-aliasing. Typical model and pictures building time: 3-10
minutes (700 MHz Pentium PC).
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Each of the above three methods is activated by a separate button in the top toolbar:

3D Quick
View
+
Rot/Zoom

•

3D Solid
View
+
Rot/Zoom

3D Photo
(four
static
views)

Using the first option “3D Quick View”:
We will use the “3D Quick View” option since our model consists of rectangular sections
only.
Click LB on 3D Quick View button [

] in the top toolbar.

A new window appears, and it shows the quick view model.

Passivation Layer

Field Oxide

Bulk Silicon
Buried Oxide
Figure 2. 3D solid model of the IC chip in CFD-Micromesh. Unlike Figure 1, the heat sink does
not appear here because we unchecked the “Mesh it” box for the Sink material.

In the “3D Quick View” window, use LB - to rotate the model, MB - to zoom in
and out the view and RB - to shift (pan) the view. Hover the cursor over different
layers in the structure to see the layer name.
To get a better view of the structure, click the Scale Solid button [
] in the top
toolbar, enter a value of 4 for the Z direction scaling, and click Accept.
Close the “3D Quick View” window.
•

Viewing the “internal” structure, i.e. metal layers, contacts, vias etc.
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Click LB on the FOx layer name.
Click RB -> Edit Material, and uncheck the Mesh It box.
Click Close, and then Accept.
Likewise, uncheck the Mesh It box for Pass layer name.
Save the Micromesh Project file, and click the 3D Quick View button in the top
toolbar. A solid view of the IC chip, similar to the Figure 1(b), appears in a new
window.
Click the Scale Solid button in the top toolbar, enter a value of 3 for Z direction
scaling, and click Accept. The solid model appears similar to the following figure:

Close the “3D Quick View” window.
Re-check the Mesh It box for FOx and Pass layer names, and save the
Micromesh Project file.
12. Automatic building of a 3D computational mesh

•

Select the Structured Mesh button [

] from the top toolbar (or from the top menu:

Compute -> Structured Mesh).
The "Structured Mesh - Generation Parameters" window appears. By setting the
numbers in this window, you may control the quality and resolution of the generated 3D
mesh that will finally be stored in the DTF file.

•

For the mesh of this tutorial, set the parameters as below:
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In this tutorial, leave the Copy BCs, VCs, and Simulation Data box unchecked. In the
first run, boundary conditions (BCs), volume conditions (VCs) and other simulation
parameters have to be manually assigned in the DTF file, through the Graphical User
Interface (GUI). However, if a change in the device structure or meshing scheme is
desired at a later stage, you may copy the simulation parameters (including BCs, VCs)
from an existing DTF file by checking the box and specifying the name of the source DTF
file.
Before generation of the model, the user is asked to save the project under a
chosen name. Answer Yes to the “Save file now?” question.
The progress of the grid generation process is displayed in the "Status" window. The
message "COMPUTATION COMPLETED" appears at the bottom when the 3D mesh is
ready and has been saved in a DTF file. Note that the DTF file has exactly the same
name as the Micromesh Project file we saved earlier (heatchip.DTF in this case)

Viewing the generated 3D computational mesh (DTF file)
13. Select the CFD-VIEW button [

] from the toolbar.

This button invokes the CFD-VIEW program installed on your machine as part of the
CFDRC software. The DTF file just generated by CFD-Micromesh is opened
automatically in CFD-VIEW. Please refer to the CFD-VIEW Manual from CFDRC for all
the details of operation of this program.
14. In CFD-VIEW :

•

In the Objects window list in the lower-right corner, select all the items of Type Wall.
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From the toolbar above the viewing window, select the following buttons (hover
the mouse cursor over the buttons to see their description):

o

Grid on and Flooded on

Select Scaling [
] tab along lower portion of window. Set the Z value to 3.
Press Enter on your keyboard.
•

Use LB to rotate the 3D mesh, MB to zoom in or out the figure, RB to translate it.
With a little change in the viewing direction and zooming in on the device, your meshed
model in CFD-VIEW should look similar to the one shown below.

Figure 3. Structured mesh created for the IC chip.

•

Close CFD-VIEW by selecting File -> Quit and answer No to the question “Save current
model to file?”

Setting up a Heat Transfer Simulation
15. Open CFD-ACE-GUI with the generated 3D computational mesh (DTF file)
•

Select the CFD-ACE-GUI button [

] from the toolbar in CFD-Micromesh.

This button invokes the CFD-ACE-GUI program installed on your machine in the CFDRC
package. Within CFD-ACE-GUI you can apply boundary conditions appropriate to your
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problem, set up analysis parameters, and start simulations. Please refer to the CFDACE(U) User Manual from CFDRC for all the details of operation of CFD-ACE-GUI.

•

When started from Micromesh, GUI should automatically open the DTF file you just
created (heatchip.DTF). If it does not open the DTF file automatically, open the DTF file
using the menu command: File -> Open ... heatchip.DTF.
After adjusting the view of the 3D meshed model in the GUI viewing window, the device
should appear similar to the illustration below.

16. Steady-state simulation with a surface source
•

PT (Problem Type)
Check the Heat Transfer (Heat) module.

•

MO (Model Options)
In the Shared and Heat panels leave all parameters at their default settings.

•

VC (Volume Conditions)
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Check the volume name list at the bottom of the GUI to make sure that all
volumes have the Solid VC type. If for some reason this is not the case, click
Ctrl-A. In the Properties drop-down list at right, select Solid, and click Apply.
Select the BulkSi volume name by clicking LB on it. While keeping Ctrl pressed,
also click LB on the DevSi volume name. Both of them should be highlighted.
Click the Group button at the bottom. (You may be prompted that they already
belong to a group. Simply click the Ungroup button THEN click on the Group
button.)
o

In the Phys panel:
Set the Density as 2330 kg/m3.

o

In the Heat panel:
Set the Specific Heat at 710 J/kg.K.
Set the Thermal Conductivity at 148 W/m.K

o

Click Apply.

Select the BOx volume name by clicking LB on it. While keeping Ctrl pressed,
also click LB on the FOx and Pass volume names. All three of them should be
highlighted. Click the Group button at the bottom. (You may be prompted that
they already belong to a group. Simply click the Ungroup button THEN click on
the Group button.)
o

In the Phys panel:
Set the Density as 2270 kg/m3.

o

In the Heat panel:
Set the Specific Heat at 1000 J/kg.K.
Set the Thermal Conductivity at 1.4 W/m.K

o

Click Apply.

Select the Contact volume name by clicking LB on it. While keeping Ctrl
pressed, also click LB on the Via, Met1 and Met2 volume names. All of them
should be highlighted. Click the Group button at the bottom. (You may be
prompted that they already belong to a group. Simply click the Ungroup button
THEN click on the Group button.)
o

In the Phys panel:
Set the Density as 8920 kg/m3.

o

In the Heat panel:
Set the Specific Heat at 386 J/kg.K.
Set the Thermal Conductivity at 410 W/m.K

o
•

Click Apply.

BC (Boundary Conditions)
You should observe that only four BCs have the Wall BC Type, and the others have the
Interface BC type.
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Select the Sink_BulkSi wall BC name:
o

In the Heat panel at right, set the sub-type to Isothermal with a constant
temperature value of 300 K.

o

Click Apply.

Select the FOx_DevSi interface BC name:

•

o

In the Heat panel at right, check the Wall Heat Source box.

o

Enter a constant Wall Heat Source value of 1E+7 W/m2.

o

Click Apply.

IC (Initial Conditions)
Leave all parameters at their default values.

•

SC (Solver Control)
In the Iter panel, set Max. Iterations to 30, and Convergence Crit. to 1e-7

In the Solvers panel, change Enthalpy solver to AMG
In the Relax panel, change the Inertial Relaxation parameter for Enthalpy to
1E-13
•

Out (Output Parameters)
Under the Print sub-panel, check the Heat Trans. Sum Box.
Under the Graphic sub-panel, set the output variables you want to see in CFDVIEW. You may turn off the variables that you do not need.
For example, for the Heat Transfer simulation, you may turn on:
Static Temperature
Wall Heat Flux

•

Run
Click Submit to Solver.
A new window opens up asking you whether you want to submit the simulation under the
same name or a different name.
Click the Submit Job Under Current Name button.
Click View Residual.
If the values of the residuals eventually go down by 5-6 orders of magnitude, it typically
means the calculations converge properly, as illustrated below.
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NOTE: There is a colored dot in the upper right corner of the residual window. This dot
is an indicator of whether the simulation is running (green) or has stopped (red). Also,
you might have to wait for a few seconds after clicking the Submit button, for the variable
names and residual curves to appear in the window. This is because variable
initialization, memory allocation, and even the solution itself can sometimes take a while
(e.g. 3D cases with a large number of cells).
Click View Output
The output file contains a Heat Transfer Summary at the end. A good heat balance in the
Heat Transfer Summary may also be treated as an indicator of a properly converged
solution. At steady state, the heat entering a boundary should be equal to the heat
leaving the boundary (except in the case of a heat source or sink). This is clearly
observed in the boundary-by-boundary heat transfer summary in the following figure.
The “Elapsed Time” value at the bottom of the Output file shows the CPU time for that
simulation, in seconds.
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Post-processing using CFD-VIEW
This section shows how to use CFD-VIEW to obtain color contours for temperature, wall heat flux
etc. It also describes how to obtain line plots for temperature variations in a cross-section. For
more details on how to use VIEW refer to the CFD-VIEW User Manual.

•

As earlier, click the Launch CFD-VIEW button [

] in the top toolbar of GUI.

A new CFD-VIEW window displaying the IC chip structure of heatchip.DTF should open.
CFD-VIEW may also be launched on it’s own, then Click the Import DTF or Plot 3D
button [

] and open the file heatchip.DTF.
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Color Contour Plots Of Full Geometry
•

In the Objects window in the lower-right corner, select all the objects of type Wall

•

From the top toolbar, select Flooded On [

•

From the Color: drop-down list along the top toolbar, select T

•

Use LB to rotate the 3D mesh, MB to zoom in or out the figure and RB to pan the figure.

]

Make sure you have a convenient view of the IC chip to begin with.

•

Add a legend to the screen by clicking on the Add Legend button (

) located in the

upper right panel of objects
•

The temperature color contours should look similar to the following:

•

To turn off previous contour plot: In the Objects window in the lower-right corner, select
all the objects of type Wall and select Flooded Off [
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Color Cut-Plane Contour Plots
•

Another useful feature of CFD-VIEW is the ability to view variable distributions in various
cross-sections (or cut-planes).

•

In the Objects window in the lower-right corner, select the Zone object named Zone#1

•

In the upper right hand section of the screen, click the Z-cut button (

) (Note: A new

object called Z-Cut is added to the object list and now highlighted)
•

From the top toolbar, select Flooded On [

•

From the Color: drop-down list along the top toolbar, select Wall Heat Flux

]

By default, the various cut planes are positioned at the center of the structure. The
position can be changed using the slider located above the object list on the right.
•

Using the slider bar, set the location of the Z-cut at 1e-6
The following wall heat flux distribution should be seen:

Such cut-planes can be created in any of the 3 directions, and can be used in conjunction with
each other as well. (To remove the Z-Cut object, select Z-Cut from Object list window and hit
Delete key)
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Line Plots
In some cases, simulation results are better represented by means of a line plot in a crosssection of the device.

•

In the Objects window in the lower-right corner, select the Zone object named Zone#1
In the upper right hand region, select the Line Probe button (
), which creates
and highlights a new Line Probe object in the lower right object list
Above the object list, set the following values for Point 1 (start point of the plotline) and Point 2 (end point of plot-line):
o

Point 1:

X: 2.62e-5,

Y: 1.25e-5,

Z: 1.74e-6

o

Point 2:

X: 2.62e-5,

Y: 8.75e-5,

Z: 1.74e-6

In the upper right hand region, select the Plot button (
highlights a new Plot object in the lower right object list

), which creates and

Above the object list, set Plot X-Axis to variable Y and Plot Y-Axis to variable T
Check External Plot box to generate plot as seen below

We can clearly observe the variations in temperature across the cross-section of the IC chip. The
silicon devices are the hottest regions, while the surrounding areas have a relatively lower
temperature. The sudden dips in temperature are due to the presence of metallic contacts. Being
good thermal conductors, they conduct heat away efficiently and their temperatures are lower.
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Steady State Solution with Volumetric Heat Source
The procedure for setting a volumetric heat source in CFD-GUI is similar to setting a surface heat
source. The heatchip.DTF file created earlier may be used for this simulation too.
17. Assuming the heatchip.DTF file is still open in the CFD-ACE-GUI window, click File -> Save
As…, and save the DTF file as “heatchip_volsrc.DTF”. This will prevent overwriting of the
earlier DTF file with the results of our surface heat source simulations. We will work with the
heatchip_volsrc.DTF file for this simulation.
18. Set-up and run a new simulation in the following manner:
•

PT (Problem Type) and MO (Model Options)
Follow the same procedure as in the surface heat source case.

•

VC (Volume Conditions)
Select the DevSi volume name. BulkSi also gets highlighted since the two are
grouped. Click the Ungroup button at the bottom to separate the two volume
names.
Change the VC setting mode drop-down list on the right from Properties to
Heat
Select the DevSi volume name
o

Check the Heat Source button

o

In the Heat Source drop-down list, select Fixed Source (Volumetric),
and enter a value of 2E14 W/m3.

o

Click Apply.

You may now change the VC setting mode drop-down list on the right from Heat
back to Properties if you desire, as this is the default mode.
•

BC (Boundary Conditions)
Ensure that the Sink_BulkSi face is isothermal at 300K
Select the Fox_DevSi interface:

•

o

Uncheck the Wall Heat Source button

o

Click Apply

IC (Initial Conditions) and SC (Solver Control) and Out
Leave the earlier settings as set for the previous surface heat source simulation.

•

Run
Click Submit to Solver. In the new window that opens, click Submit Job Under
Current Name.
The Residual and Output files after simulation should look similar to the following:
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Viewing the results
The temperature and wall heat flux distributions in CFD-VIEW should look similar to the following
figures. The temperature distribution is shown below in a Z-cut at Z = 2.9E-6 m from the bottom.

The wall heat flux is shown below in a Z-cut at Z = 1E-6 (i.e. at the bottom of the chip).
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A plot of temperature, along the dotted line shown in the above figure, should look similar to the
following plot. (This line plot end points are identical to the points described for the previous
simulation VIEW results).

We can clearly observe the variations in temperature across the cross-section of the IC chip. The
silicon devices are the hottest regions, while the surrounding areas have a relatively lower
temperature. The slight decrease in temperature at the ends of the silicon devices are due to the
metallic contacts, as in the surface source case earlier.
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