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B 

Exercise Introduction 

1. Exercise Aim and Plan 

The aim of this exercise is to investigate the different components of power loss in a 

semiconductor switch including their variations with switching frequency. This also creates an 

opportunity to use computer simulation for analysing the operation of power semiconductor devices 

and circuits. 

The abovementioned problem will be analysed based on a specific device example: the MOSFET. 

Thanks to its operation being relatively simple, it will not be necessary to consider any secondary 

phenomena. The transistor will operate in its simplest circuit configuration: the low-side switch; it will 

be used to realise the function of the simplest power electronic converter: a DC voltage chopper. 
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2. Power Loss in MOSFETs 

2.1. Recommended reading 

Ref. Textbook Excerpt 
Equivalent in the 

Polish Manual 

Complementary 

Reading 

Complements 

in this Manual 

A* Ben 10.3.3 2.1   

B** Wil 6.3, 6.3.1, 6.3.2, 

6.3.3 

2.3.d   

   2.3.e  2.2 

* Ref. A is found in the document already published as Refs. ABC for Manual 3P. 

** Ref. B is found in the document already published as Ref. D for Manual 3P. 

 

Additionally, from Manual 3P references: 

Ref. Textbook Excerpt 
Equivalent in the 

Polish Manual 

Complementary 

Reading 

Complements 

in this Manual 

3P A Ben 10.2.1 2.2 [13] 6.3  

3P D Wil 6, 6.1, 6.1.1, 6.1.2 2.3.a—c   

Note: Ref. D is based on the example of a BJT where terminal names and the control mechanism are 

different from a MOSFET. Other than that, results and conclusions stay valid for any power transistor. 
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2.2. Practical measurement of dynamic energy dissipation 

If we consider only the drain circuit, measuring the energy dissipated in a MOSFET in dynamic 

states always requires recording iD and uDS waveforms, their multiplication and integration: 

  ==
sup(on)

inf(on)

sup(on)

inf(on)

dd DSDDD(on)

t

t

t

t

tuitpW  (2.1) 

  ==
sup(off)

inf(off)

sup(off)

inf(off)

dd DSDDD(off)

t

t

t

t

tuitpW  (2.2) 

where tinf(on) and tsup(on), and tinf(off) and tsup(off) are the integration limits.1 

To enable practical measurements and, at the same time, result standardisation, the integration 

limits are determined based on characteristic relative values of relevant waveforms, as in the case of 

determining time-related parameters (see Manual 3P, Section 2.2). According to international standard 

IEC 60747-8-4, when energy is concerned, the tinf and tsup moments are defined by the relative values 

of 10% of the iD and uDS waveforms, as illustrated in Fig. 1. 
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Fig. 1. Method for determining energy-related parameters of the MOSFET 

according to IEC 60747-8-4 

Inductive load is the most characteristic for devices operating in power electronic converters as 

well as because it involves highest power losses. Therefore, the standard requires this type of load to 

be used when measuring energy-related parameters of MOSFETs. 

 
1 In the case of macroscopic characterization of power semiconductor devices, the symbol E has been 

customarily adopted (also in the standard) for energy dissipation. However, in accordance with references and 

the majority of scientific publications and textbooks, we will use the symbol W. This is for two reasons: 1° to 

distinguish energy from electric field and 2° for consistency with reference chapters on energy bands and energy 

transfer in power conversion systems. 
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3. DC Voltage Chopper 

3.1. Pulse wave-based control 

3.1.a. Pulse wave 

As opposed to linear-mode circuits, in switched-mode ones, the semiconductor device is fully on 

(with the lowest voltage drop possible across it) for some time interval and it its fully off (will a 

virtually zero current flow) for the rest of the time. Thanks to this approach, power loss is greatly 

reduced. To achieve such an operation mode, a suitable control is necessary, where the control signal 

is not time-continuous, but changes abruptly. 

In pulse wave-based control, a controlling quantity x (current or voltage) takes the form of a pulse 

wave. It consists of periodically repeated pulses, i.e. sections of a level higher than the idle one, whose 

shape, to simplify, can be considered rectangular [see Fig. 2(a)]. 

A pulse wave is described by the following parameters: 

(1) repetition period Tp which is the shortest time interval after which values of the 

considered quantity repeat; therefore, it is e.g. the interval between the beginnings 

of successive pulses; 

(2) repetition frequency fp which is the inverse of the repetition period: 

 
p

p

1

T
f =  (3.1) 

(3) pulse width tp which is the duration of the top of the pulse; 

(4) duty cycle (also called duty ratio) D which is the ratio of the pulse width to the 

repetition period: 

 
p

p
Δ

T

t
D =  (3.2) 

As it can be easily seen, just one of the parameters 1 or 2 and one of the parameters 3 or 4 are 

sufficient for an unambiguous description of a pulse wave in the time domain. 

In the domain of the electrical quantity considered (current or voltage), a pulse wave is described 

by: 

(5) low level XL which is the value of the quantity x corresponding to the base of the 

pulse; 

(6) high level XH which is the value of the quantity x corresponding to the top of the 

pulse; 
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(7) amplitude Xm which is the distance between the low and the high levels 

 LHm XXX −=  (3.3) 

As it can be easily seen, any two of the parameters 5 to 7 are sufficient for an unambiguous description 

of a pulse wave. 

In power electronics, waveforms with a zero base level (XL = 0) can often be seen, for which 

XH = Xm. Because of the prevalence of this case and due to the considerable simplification of 

relationships that are obtained, it is usually the zero base level that is assumed in analysis. 
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Fig. 2. Pulse wave and its basic parameters: (a) the ideal waveform; (b) a waveform with finite edge steepness 

3.1.b. Parameters of a real pulse wave 

The abovementioned parameters fully describe only ideal pulses, which cannot be generated in 

practice. For example, the non-zero edge duration is one of the features of a real pulse wave. The 

edges are additionally described by [see Fig. 2(b)]: 

(8) rise time tr, i.e. the time it takes for the waveform to rise from 10% to 90% of its 

amplitude, which is a measure of the duration of the rising edge (also called the 

leading edge); 

(9) fall time tf, i.e. the time it takes for the waveform to fall from 90% to 10% of its 

amplitude, which is a measure of the duration of the falling edge (also called the 

trailing edge). 

If the above times are shorter than the shortest pulse width in a given circuit, then their effect on its 

behaviour can be neglected. 

A more detailed analysis or design of pulse wave-controlled power converters may require 

considering additional factors such as overshoots, settling time, frequency or phase jitter. They can 

negatively affect circuit operation. 
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3.2. Single transistor switch as a DC/DC power converter 

3.2.a. Low-side switch 

The simplest configuration of a transistor switch is the low-side switch. Using this topology, a DC 

voltage chopper can be realised, which is the simplest pulse wave-controlled DC/DC power electronic 

converter. Its schematic is presented in Fig. 3. 

The term “low-side” indicates how the semiconductor switch (the transistor Q in Fig. 3) is located 

with respect to the load (the resistor RL in Fig. 3). In this configuration, the switch is found on the side 

of the lower potential (negative terminal) of the source UDD. In the opposite case, when the switch is 

located on the side of the higher potential (positive terminal) of the source, the configuration is called 

“high-side switch.” 

 

ug 

UDD 

RL 

D 

Q G 
RG 

S 

 

Fig. 3. The schematic of the low-side switch 

circuit to be used in simulations  

On the other hand, the term “chopper” refers to the function fulfilled by the considered circuit 

from the point of view of electric power conversion. This function is to periodically remove power 

supply from the load, thus causing the voltage waveform across the load (receiver) to appear as 

“chopped.” The transistor’s operating state changes according to the controlling pulse wave ug: 

(1) when the transistor is on, the resistance between its source and drain is low, which 

enables current flow in the power loop. Assuming that the transistor is an ideal 

switch, it represents a short-circuit, so the full supply voltage UDD is applied to the 

receiver RL (see Fig. 4a); 

(2) when the transistor is off, the resistance between its source and drain is high, 

which disables current flow in the power loop. Assuming that the transistor is an 

ideal switch, it represents a break in the circuit. As no current is flowing, the 

voltage across the RL resistor is zero (see Fig. 4b). 

(a)  

Io 

RL 

S 

D 

UDD 

 

(b)  

S 

D 

RL 

UDS UDD 

 

Fig. 4. Power loop of the chopper circuit for an ideal 

semiconductor switch:  (a) in the on-state;  (b) in the off-state 
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3.2.b. Chopper as a DC/DC converter 

Any change in the duty cycle D of the ug waveform entails a change of the time interval length 

when the transistor is on. As a result, the average value of the output voltage (across the load) uo: 
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Considering that the duty cycle takes values from the range of [0; 1], the considered circuit 

realises the function of lowering the average value of the output voltage. As the average value is equal 

to the direct component of a signal, this circuit can therefore be classified as a DC/DC power 

converter. However, it is so simple that it does not include an output filter. Consequently, in this case, 

the output voltage uo takes a pulse form instead of a constant one (not even approximately). 

Electric power conversion is characterised by the average power (see Manual 0, Ref. C). 

According to its definition and based on the analysis results from Section 3.2.a, for a DC voltage 

chopper this power equals 
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Similar to the direct component of the output voltage, the output power is a linear function of the 

duty cycle. Therefore, by varying the duty cycle, it is possible to regulate the average value of the 

voltage supplying the load and thus, the average power supplied to the load. This proves that the 

analysed circuit indeed fulfils the task of a power converter. 
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C 

Experiment 

4. Simulations 

4.1. Completing the schematic and configuring simulation 

Circuit under analysis 

A schematic of the circuit to be investigated by simulations is presented in Fig. 5. The gate resistor 

RG has a value of 100 Ω; this value is relatively high and has been chosen to emphasise effects 

observed. Other components’ values are determined for each team individually. 
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Fig. 5. The schematic of the low-side switch 

circuit to be used in simulations  

A model of the IRF620 component will be used for the transistor Q. This model comes in two 

variants, corresponding to different operating temperatures: the standard room temperature of 25 °C 

and the maximum rated one (for the considered transistor) of 150 °C. These two models have been 

differentiated by the suffix “_xC” added to the designation, where x is a temperature value in degrees 

Celsius. 

The pulse wave source ug is to represent a real control circuit in the form of an integrated gate 

driver, IR2117, whose data sheet is attached to this manual. For simplicity, in this exercise it will be 
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assumed that the driver’s output resistance is zero, thus its output voltage toggles between the level of 

0 V and the supply voltage of the control circuit. In order to drive the gate of the transistor Q properly, 

a value of 15 V will be used for the latter. The control waveform frequency is established individually 

whereas its duty cycle should be set at 0.5. 

Sources and passive components 

1. In the MicroSim environment, create a new project containing a preliminary circuit schematic: 

(a) from the Start ‣ Projektowanie menu, launch Design Manager from the MicroSim 8 package; 

(b) in the Design Manager window, create a folder for  the new project: 

 select File ‣ Workspace from the menu, 

 in the Location field, enter or select (using the “…” button) the path for a folder 

(conforming to laboratory regulations) where the project is to be created, 

 click Create; 

(c) copy the file lacznik_dolny.sch, which contains a schematic corresponding to the circuit of 

Fig. 5, to the project folder created; 

(d) in the project window in Design Manager, unfold the Schematics list and double-click the file 

just copied, which should cause it to be opened in the Schematics application. 

2. Modify names of all circuit components by changing the characters “??” to your team number 

(e.g. UG99). 

Results obtained in circuits with unsuitable component names will be considered as cheated. 

3. From the web page, obtain initial values for switching frequency fs,ini, power loop supply voltage 

UDD and on-state drain current ID(on). 

4. Based on appropriate values from step 3 and representing the transistor with an ideal switch (see 

Section 3.2.a), calculate a load resistance RL such that when the power loop is supplied with a 

voltage of UDD, the on-state drain current equals ID(on). 

5. Based on appropriate data, complete the schematic with component parameters: 

(a) after double-clicking the symbols “?” located by the respective components, enter the values 

for RG, UDD and RL (see steps 3 and 4); 

(b) double-click the uG source symbol and enter the parameters of the control waveform: 

The MicroSim environment enables introducing numbers with unit prefixes. For circuit description 

(i.a. in Schematic) these are: f, p, n, u (meaning µ), m, k, Meg (meaning M), G, and are case 

insensitive. In the case of Probe, they are: f, p, n, u, m, k, M, G, and are case sensitive. Results will 

be presented in Probe in this form, too. Units or their prefixes must not be separated with spaces 

from numbers. 

The simulators of the SPICE family have their own circuit description language where dot is the 

decimal sign (so comma is not). This format applies to any application within the MicroSim 

package, independent on operating system settings. 

 PER for period Tp, which should be calculated using the known frequency fs,ini (see step 3), 

 PW for pulse width tp, which should be calculated using the known frequency fs,ini and 

duty cycle D (see step 3, the description of the circuit under analysis above and Section 

3.1.a), 

 TD for delay time, equal 0, 

 TR for rise time tr, equal to the rise time tr of the output signal of the gate driver specified 

above, according to its data sheet (use the typical value, i.e. the one listed in the typ 

column), 

 TF for fall time tf, equal to the fall time of the output signal of the gate driver (by analogy 

to TR), 

 V1 for the low level UL, equal 0 V (a value typically used to turn off a transistor), 
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 V2 for the high level UH, equal 15 V (a value that ensures the transistor will turn on with a 

low uDS voltage drop). 

6. Insert the transistor into the circuit (menu Draw ‣ Get New Part, or Ctrl+G), using the model 

variant for the junction temperature of 25 °C; name it according to the guideline given in step 2. 

Starting the simulation 

MicroSim and Probe manuals available at the laboratory stand may be helpful in performing 

simulations. 

7. Define simulation parameters: 

(a) open the Analysis Setup dialog using the Setup Analysis icon (or by selecting Analysis‣ Setup 

from the menu); 

(b) select transient analysis only by checking the selection box next to the Transient button and 

unchecking all the other boxes; 

(c) click the Transient button and set: 

 Final Time, which is the time when simulation is finished, such that periodic operation of 

the circuit with the frequency obtained in step 4.1/3 can be observed, 

 Print Step, which is the step of dumping results to a text file, should be as large as 

possible to speed up the simulation as this text file will not be used, however, it cannot be 

lower than Final Time, 

 Step Ceiling, which is the upper limit for the simulation step (the distance between 

subsequent time points), to 5 ns (approximately 1/5 of the transistor’s switching times), 

which will enable a sufficiently high waveform resolution to be obtained in dynamic states 

while keeping the computation time acceptable; 

(d) close the Transient and Analysis Setup dialogs; 

(e) select Analysis ‣ Probe Setup from the menu and enable: 

 running the Probe application automatically after simulation is completed (Automatically 

run Probe after simulation), 

 displaying waveforms marked in the schematic (Show all markers). 

8. Place a current marker (the Current Marker icon or Markers ‣ Mark Current into Pin menu item) 

so that to measure the transistor’s drain current. 

The power MOSFET model used has the form of a sub-circuit. For this reason, it is impossible to apply 

a current marker to any of its graphical symbol’s terminals Therefore, the drain current must be 

measured in any other component of the circuit where, according to the schematic, this current also 

flows. 

If the Add Trace function is used in Probe, no quantities from inside the transistor model sub-circuit 

should be plotted; these can be recognized by the letter “X” in their names. They can be hidden in the 

Add Trace dialog by unchecking the Subcircuit Nodes option. Even though quantities named ID, IG etc. 

appear among them, these are currents of a transistor that is just one part of the model and whose 

currents are not identical with terminal currents of the power MOSFET under investigation. 

9. Perform a preliminary simulation of the circuit: 

(a) start the simulation with the Simulate icon (or by selecting Analysis ‣ Simulate from the menu, 

or by pressing F11); the PSpice A/D application should be opened; 

(b) in case of any error, determine and eliminate its cause using the manual for the MicroSim 

environment; 

after the simulation successfully completes, the Probe application should be launched and the 

transistor’s drain current waveform should be displayed; 

(c) check if the final simulation time has been chosen adequately [see step 7(c)]; if not, modify 

simulation settings as appropriate and re-run the simulation; 

(d) if the sign of the current is incorrect, obtain a correct result according to the remark below. 
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It follows from the topology of the power loop and from Kirchhoff’s voltage law that the 

transistor’s drain current is positive following the arrows convention adopted in electrical 

engineering. If the sign of the current displayed in Probe is negative, then this is just a result of the 

marker being applied in Schematic to a terminal whose current has a conventional direction 

opposite to the true drain current in the circuit. A user does not have any influence on the way 

voltages and currents are assigned their directions by the simulator; this is predefined in component 

models and symbols with no relation to a particular circuit. In such a case, the waveform should be 

corrected by moving the current marker to the other terminal of the component in Schematics (re-

running the simulation is unnecessary provided the MicroSim package is correctly installed and 

operated) or by adding a minus sign (“-“) in the waveform definition in Probe after double-clicking 

its label under the plot. 

10. Add voltage waveforms to the plot: 

(a) create an additional Y-axis by selecting Plot ‣ Add Y Axis from the menu; the new axis 2 

should be marked as the active one with a “>>” sign; if not, click the axis to select it; 

(b) by adding voltage markers in Schematics (Voltage/Level Marker icon or menu item Markers ‣ 

Mark Voltage/Level), plot the following against axis 2: dran-to-source voltage uDS, control 

voltage ug and gate-to-source voltage uGS; 

In this specific case, it is possible to use simple voltage markers, because according to the circuit 

schematic, the reference potential for each of the above voltages is zero; otherwise voltage 

differential markers would have to be used (menu item Markers ‣ Mark Voltage Differential). 

(c) determine whether the waveforms shown are proper for the switch-mode operation of a 

transistor as well as whether transistor control and switching occur with the frequency and 

duty cycle used in step 4.1/5(b); if not, check if the circuit parameters entered are correct and 

if the transistor’s model has been properly selected. 

If simulation has to be repeated, it is possible to restore the previous view (i.e. axis and waveform 

layout) in Probe by selecting Tools ‣ Display Control from the menu and double-clicking the Last 

Session item, or alternatively, by pressing F12. 
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4.2. Power loss and effect of switching frequency 

Instantaneous power loss in the transistor 

1. Add a new sub-plot containing the instantaneous drain power loss waveform: 

(a) create a second sub-plot (Plot ‣ Add Plot from the menu); the new sub-plot should be marked 

as the active one with a “SEL” label; if not, click anywhere inside the sub-plot to select it; 

(b) copy the drain current waveform iD from the lower sub-plot to the upper one by selecting it 

with a click on its label below the graph (the label should become highlighted in a different 

colour) and then invoking the Copy and Paste functions using the menu, appropriate icons or 

keyboard; 

(c) double-click the label of the copied waveform (below the upper sub-plot) and modify its 

defining mathematical expression (Trace Expression) so that it represents the transistor’s drain 

power loss pD (see Section 2.2 or Ref. A); for quantities other than iD, appropriate designations 

that Probe can understand should be read out from waveform labels below the lower sub-plot; 

note that, the transistor being a dissipative (as opposed to generating or storing) component, 

the curve obtained must exhibit positive values [if this is not the case, see the remark under 

step 4.1/9(d)]. 

If a formula involves a combination of the multiplication sign and the minus sign, the expression 

that contains the minus sign must be enclosed between parentheses; otherwise a calculation error 

may arise which will make the application close. 

2. To prevent an accidental loss of work results related to plot configuration, save present view 

settings (i.e. sub-plot, axis and waveform settings) by selecting Tools ‣ Display Control from the 

menu, providing a name for the view in the New Name field and clicking Save. 

To later restore the saved view settings, select the respective view name from the list and click Restore. 

3. From the plot, read out peak instantaneous power loss pD(pk) in each of the operating states of the 

transistor 

(a) using the View Area function (an icon in the toolbar, or View menu), zoom in the time scale so 

that to observe the transistor’s turn-on state (cf. Fig. 6): 

The View In function should not be used for zooming waveforms in this exercise. This is because 

waveforms will have to be zoomed mostly in the time axis and much less so (or not at all) in the Y-

axis, while the View In function scales both axes at an identical ratio. 

The View Area function should best be used in the current and voltage sub-plot (as opposed to the 

power and energy sub-plot). This is because this way, power and energy scales will be 

automatically adjusted to their respective ranges within the magnified time interval. 

(b) activate cursors using the Toggle cursor icon (or by selecting Tools ‣ Cursor ‣ Display from 

the menu); 

(c) move cursor 1 to the instantaneous power waveform pD by clicking the graphical symbol left 

of the respective waveform label below the appropriate sub-plot, which should result in a 

frame appearing around the symbol; 

(d) using the View Area (to zoom in) or View Fit (to zoom out) functions, with the cursor, read out 

(see Fig. 7) the peak value of the instantaneous power loss pD(pk) (cf. Fig. 6) in each of the 

transistor’s four operating states (i.e. turn-on, conducting, turn-off and blocking), while 

considering the following: 

 the first two switching periods should be ignored as the simulated circuit might not reach 

its steady state yet; 
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 the operating state should be determined based on the observation of the drain current 

waveform iD; 

 by definition, in static states, the power does not change, so the peak value is identical to 

the constant value of power in these states; 

 because a small variation of the power value in static states is observed in reality, make 

your readouts always in the middle of the time interval corresponding to the static state 

under consideration (see Fig. 6). 

t

ttinf(on)

uDS

iD

110% pD(cond)

pD(t)
pD(pk)(on)

∆WD=WD(on)

WD(t)

tsup(on)

pD(cond)

tinf(off) tsup(off) tinf(on)′

pD(pk)(off)

pD(b)

 

Fig. 6. Readout example of peak instantaneous power loss pD(pk) and of energy dissipation 

WD in the different operating states 
 

Fig. 7. Interpretation of values displayed in the Probe Cursor 

floating window 

Energy dissipation in the transistor 

4. Additionally display a waveform for the energy dissipated in the transistor: 

(a) in the upper sub-plot, create a second Y-axis and make sure it is the active one [see steps 

4.1/10(a) and 4.2/1(a)]; 

(b) copy the instantaneous power waveform pD from axis 1 to axis 2 by selecting it with a click on 

its label below the graph and then using the Copy and Paste functions; 

(c) double-click the label of the copied waveform and modify its defining mathematical 

expression so that it represents the energy WD(t) dissipated in the transistor’s drain circuit from 

zero time to a time of t (cf. Section 2.2): 

 =
t

ptW
0

DD d)()( ττ  (4.1) 

Cursor 1
(left mouse button)

Cursor 2
(right mouse button)

Cursor 1 – Cursor 2 
Difference

X-Coordinate 
(e.g. time) 

Y-Coordinate 
(e.g. voltage or power) 
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where τ is an auxiliary integration variable which for each time point t sweeps the time axis in 

the range of 0 to t. 

For the purpose of calculating an integral of this kind, the function S() can be used in Probe, 

defined as: 

 ==
t

gtfg
0

d)()()S( ττ  (4.2) 

where g can be any expression involving quantities available in Probe. 

5. Restore default axis scales with the View Fit icon or by selecting View ‣ Fit from the menu. Next, 

save the present view settings (see step 2). 

6. Save the graph with at least one full switching period of the transistor visible: choose Tools ‣ Copy 

to Clipboard from the menu, then paste to a text document or to a graphics editor and save to a 

file. 

7. Move cursor 1 to the energy waveform WD(t) [see step 3(c)]. Using the cursor (see Fig. 7), from 

the waveform, read out values of energy WD at the five time points corresponding to (see Fig. 6): 

 the beginning of the turn-on state tinf(on), 

 the end of the turn-on state tsup(on), 

 the beginning of the turn-off state tinf(off), 

 the end of the turn-off state tsup(off), 

 the end of the switching period, equivalent to the beginning of the turn-on state belonging 

to the next period tinf(on)′, 

while considering the following (cf. Fig. 6): 

 the first two switching periods should be ignored for the reasons stated earlier; 

 all the abovementioned time points must belong to a same (single) switching period; 

 boundaries of dynamic states should be determined based on the instantaneous power 

waveform; 

 the beginning of the turn-on state and the end of the turn-off state are clearly visible; 

 on the other hand, the end of the turn-on state and the beginning of the turn-off state 

should be determined based on the criterion of the instantaneous power reaching 110% of 

its steady on-state value pD(cond) as read out in step 3; to read out the value of power 

requested, you should: 

◦ temporarily move to cursor to the pD(t) waveform [see step 3(c)], 

◦ while observing the appropriate value in the Probe Cursor window, move the cursor 

to the time point at which the value of the instantaneous power pD attains the value of 

100% × pD(cond), at the end of the turn-on state or at the beginning of the of the turn-off 

state, as appropriate, 

◦ without moving the cursor in the plot, move it back to the WD(t) waveform [see step 

3(c)], 

◦ from the Probe Cursor window, read out the value of energy WD(t); 

 results should be read out with the maximum accuracy (number of significant digits) 

available, so that to ensure that the accuracy of results obtained later by subtraction stays 

sufficient; subsequently, it will be possible to round those results of subtraction 

themselves; 

 while carrying out the present step, it is best to perform step 8 at appropriate moments. 

8. Save waveforms with a magnified time scale for the turn-on state and for the turn-off state (two 

separate pictures). 

9. Calculate the energies dissipated in the four different operating states of the transistor. The energy 

in question is the difference ∆WD in the values of WD(t) between the time points corresponding to 

the beginning and the end of the considered operating state, according to formula (4.1): 
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 for the turn-on state (see Fig. 6): 

 Dinf(on)Dsup(on)D

0

D

0

DDD(on) Δ)()(d)(d)(d)(

inf(on)sup(on)sup(on)

inf(on)

WtWtWpppW

ttt

t

=−=−==  ττττττ  (4.3) 

 for the conducting state: 

 )()( sup(on)Dinf(off)DD(cond) tWtWW −=  (4.4) 

 for the turn-off state: 

 )()( inf(off)Dsup(off)DD(off) tWtWW −=  (4.5) 

 and for the blocking state: 

 )()( sup(off)Dinf(on)DD(b) tWtWW −′=  (4.6) 

Switching frequency variation 

10. Modify the parameters of the ug [see step 4.1/5(b)] so that to obtain a switching frequency five 

times higher than the present one (i.e. fs,ini ∙ 5). All the other circuit parameters, including the 

control waveform duty cycle D, should remain unchanged, which makes it necessary to modify an 

additional parameter of the source. 

11. Modify the simulation final time so that the periodic operation of the circuit can still be observed. 

All the other analysis parameters should remain unchanged. 

12. Run the simulation. After it successfully completes, in Probe, restore the view settings saved in 

step 5 by selecting Tools ‣ Display Control from the menu, choosing an appropriate settings name 

and clicking Restore. 

If settings were correct at the end of the last simulation, then they can be restored without opening the 

Display Control dialog, just by pressing the F12 key. It may be necessary to restore default axis scales. 

13. Repeat step 3 and steps 6 to 9 to obtain values of power loss and energy dissipation in the 

transistor’s four operating states for the modified switching frequency. 

14. * Repeat steps 10 to 13 while applying a switching frequency five times lower than the initial (not 

the present) one (i.e. fs,ini / 5). 
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D 

Results 

5. Processing and Analysing Results 

5.1. Power loss components 

Electronic circuit components 

1. Fill in Part 1 of the report. 

Comparison of energy dissipation and power loss components 

2. In Part 2 of the report, include the plots of the ug, uGS, iD, uDS, pD and WD waveforms obtained by 

simulation as saved in steps 4.2/6 and 8 for two (* three) different switching frequencies. 

3. In a single in Part 2 of the report, gather the numerical results read out from waveforms in Probe 

for two (* three) different switching frequencies (leave the remaining table rows empty for now): 

 the energy dissipation in each of the four operating states WD; 

 the peak value of the instantaneous power loss pD(pk) in each of the four operating states. 

4. Calculate and add to the table (see Sub-chapters 2.2 and 3.1; Ref. A; and Manual 3P, Ref. D): 

 total energy dissipation over one switching period WD(tot), according to Eq. (10.58) in Ref. 

A, by summing the four components of the integral WD found in the result table; 

 switching period Ts; 

 total average power loss PD, according to Eqs. (10.59) and (10.60) combined to yield: 

 
p

D(tot)

D(tot)pD
T

W
WfP ==  (5.1) 
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 static average power loss PD,stat, which is the part of the total average power loss brought 

by the two static states, so: 

 
D(cond) D(b)

D,stat

p

W W
P

T

+
=  (5.2) 

 dynamic average power loss PD,dyn, which is the part of the total average power loss 

brought by the two dynamic states, so: 

 
D(on) D(off)

D,dyn

p

W W
P

T

+
=  (5.3) 

5. Complete Part 2 of the report. 
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5.2. Effect of switching frequency 

Effect of switching frequency on energy dissipation 

1. Fill in Part 3 of the report. 

Effect of switching frequency on power loss 

2. Fill in Part 4 of the report. 
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E 

Information 

6. Required Knowledge 

6.1. Prerequisites 

 Power MOSFET control and main (power) terminals 

(Manual 3P, Ref. A) 

 Voltage and current waveforms during MOSFET switching under resistive load 

(including their characteristic values in the on-state and in the off-state) 

(Manual 3P, Ref. D) 

 MOSFET (drain) power loss: instantaneous power formula and waveform over a 

switching period, on-state power loss, relation of energy to instantaneous power 

(Ref. A; Manual 3P, Ref. A, Section 10.2.1; Manual 3P, Ref. D) 

 Pulse wave-based control and pulse wave parameters 

(Section 3.1) 

 DC voltage chopper circuit topology and operation 

(Section 3.2) 

6.2. Test scope 

1. MOSFET (drain) power loss and energy dissipation: instantaneous power (formula), 

average power (formula), static (formula) and dynamic (formulae for the two types of 

load) components of the average power, energy dissipation (formula). MOSFET on-

state resistance, effect of temperature, datasheet parameters. Instantaneous power and 

dissipated energy waveforms during transistor switching (juxtaposed with current and 

voltage waveforms). 

(Ref. A; Manual 3P, Refs. A, D and [13]; report) 

2. Dependence of energy dissipation and average power loss on switching frequency: 

total values and contributions of the different operating states of a transistor 

considered as a semiconductor switch, with observations explained. Parameters 

important for transistor selection for a given circuit in respect of power loss 

minimisation depending on switching frequency. 

(report) 

In the case of report contents, only the qualitative aspect (mutual relationships and the character of 

variations) is to be considered while the quantitative one (specific numerical values) can be ignored. 
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