Program Probe

opracowanie: Lukasz Starzak

1. Podstawowe funkcje

Aby Wykonaj

Dane i okna
Wezytac wyniki W programie PSPICE A/D menu File » Run Probe.
symulacji Iub

W programie MicroSim Design Manager rozwina¢ File Based Simulation,
rozwing¢ odpowiedni plik cir, rozwina¢ Output, dwukrotnie klikngé na
pliku dat.

lub

W programie Probe menu File » Open, wybra¢ odpowiedni plik dat.

Przywrdci¢ ostatnie
ogladane okno z
wykresami dla
biezacego obwodu

Wocisna¢ F12.
lub

Menu Tools » Display Control, klikng¢ dwukrotnie na Last Session.

Zapisac ustawienia
biezacego wykresu

Menu Tools » Display Control, wpisa¢ nazwe (lub wybrac z listy istniejaca)
i klikng¢ na Save i Close.

Zapisywane ustawienia to: wyrazenia opisujace wykreslone przebiegi,
skala osi oraz dodane napisy. Dane te sa zapisywane w pliku prb.

Wezytaé zapisane
ustawienia wykresu

Menu Tools »Display Control, wybrac¢ z listy nazwe i klikna¢ na Restore i
Close.

Otworzy¢ nowe okno z | Menu Window » New.
wykresami dla

biezacego pliku z

wynikami (dat)

Zamkna¢ biezace okno Menu Window » Close.

Wykresy i osie uktadu wspotrzednych

Zmieni¢ aktualny
wykres i 0§ uktadu
wspotrzednych

Klikna¢ raz na odpowiedniej osi Y. Aktualny wykres i 0§ Y dla tego
wykresu sg wskazywane przez znacznik SEL>>.

Doda¢ nowy wykres w
biezacym oknie

Menu Plot» Add Plot.

Skasowac wykres

Wybra¢ wykres do skasowania jako aktualny, nastepnie menu Plot» Delete
Plot.

Rozdzieli¢ osie X dla
poszczegdlnych
wykreséw w biezacym
oknie

Wybrac wykres jako aktualny, nastepnie menu Plot» Unsync Plot. Operacji
tej nie da sie cofnac.
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Aby

Wykonaj

Dodaé¢ nowg 0§ Y do
aktualnego wykresu

Wybra¢ odpowiedni wykres jako aktualny, nastepnie menu Plot»Add
Y Axis.

Skasowac 0$ Y

Wybrac 0$ do skasowania jako aktualna, nastepnie menu Plot ™ Delete
Y Axis.

Wykreslanie przebiegéw

Dodac¢ przebieg do
aktualnego wykresu i
osiY

Menu Trace ™ Add lub wcisng¢ Ins lub ikonka H
Wpisa¢ w pole Trace Expression odpowiednie wyrazenie.

Dostepne zmienne sa wyswietlane na lewej liscie; jednokrotne klikniecie na
ktorejs z nazw spowoduje jej skopiowanie do pola Trace Expression

(w miejsce, gdzie znajduje sie kursor, bez kasowania dotychczasowej
zawartosci).

Na prawej liscie znajduja sie dostepne funkcje arytmetyczne (zob. punkt 2).

Zmieni¢ wyswietlany
przebieg

Klikna¢ dwukrotnie na nazwie przebiegu pod wykresem lub wybrac
przebieg klikajac na nim lewym przyciskiem myszy i z menu wybraé
Edit»Modify Object.

Zmieni¢ dane w polu Trace Expression (zob. punkt 2).

Skasowac wyswietlany
przebieg

Klikna¢ raz na nazwie przebiegu pod wykresem i wcisna¢ Del.

Przenies¢ przebieg na
inny wykres i/lub 0$

Klikna¢ raz na nazwie przebiegu. Wcisng¢ Ctrl+X lub menu Edit > Cut.
Zmieni¢ aktualny wykres i 0$ na docelowe dla danego przebiegu. Wcisnac
Ctrl+C [ub menu Edit > Paste.

Zmieni¢ zmienng osi X

Klikna¢ dwukrotnie na osi X [ub menu Plot » X Axis Settings.

Wybra¢ Axis Variable i wpisa¢ odpowiednie wyrazenie w pole Trace
Expression (zob. punkt 2).

Uwaga: niektore analizy powodujq zablokowanie zmian zmiennej osi X;
nalezy do nich np. analiza TEMP dla kilku warto$ci temperatur.

O blokadzie tej funkcji informuje wyswietlany komunikat ,,Only 1
expression allowed for the X variable”.

Ograniczy¢ dostepne
wyniki symulacji do
okreslonego przedzialu
na osi X

Klikna¢ dwukrotnie na osi X [ub menu Plot » X Axis Settings.
W polu Use Data wybrac Restricted i wypetni¢ pola ... to ... (od ... do ...).

Przywroci¢ dostepnosé
pelnego zakresu danych
znajdujacych sie w
pliku dat

Klikna¢ dwukrotnie na osi X lub menu Plot» X Axis Settings.
W polu Use Data wybra¢ Full.

Zakresy osi ukladu wspotrzednych

Zmieni¢ zakres warto$ci
na osi

Klikna¢ dwukrotnie na osi lub wybrac os jako aktualng i z menu wybra¢
Plot»Y Axis Settings.

W polu Data Range wybra¢ User Defined i wypetni¢ pola ... to ... (od ...
do ...).

Wiaczy¢ automatyczny
dobor zakresu na osi

Klikna¢ dwukrotnie na osi lub wybrac o$ jako aktualng i z menu wybrac
Plot»Y Axis Settings.

W polu Data Range wybra¢ Auto Range.
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Aby

Wykonaj

Zmienic¢ skale na

Klikna¢ dwukrotnie na osi, w polu Scale wybra¢ odpowiednia opcje (Log

logarytmiczna/liniowa lub Linear).
lub
Wybra¢ odpowiednig 0§ jako aktualng i skorzystac z ikonki m| (dla osi X)
lub % (dla osi Y).
Kursory
Wyswietli¢/ukry¢ Tkonka H 1ub menu Tools» Cursor » Display lub Ctrl+Shift+C.
kursory

Kursor 1 przesuwa si¢ lewym przyciskiem myszki, kursor 2 — prawym
przyciskiem. Kursory przesuwaja sie po odpowiednim aktualnym
przebiegu.

nhe Cursor
A1 = 953 _633K,

7F30_488m | «<— Pozycjakursora 1
F12.749m | «— Pozycjakursora 2
17 .748m | «— Roznica miedzy
pozy cjami k urs orow
? (kursor 2 —kursor 1)

A2
dif

976 .542K,
-22 908K,

Oznaczenie okna ?
0s X 0osY

Zmieni¢ aktualny
przebieg dla danego
kursora

Dla kursora 1: klikna¢ lewym przyciskiem myszki na symbolu graficznym
znajdujacym si¢ po lewej stronie wyrazenia opisujacego przebieg (pod osia
X).

Dla kursora 2: klikna¢ prawym przyciskiem myszki na symbolu
graficznym znajdujacym sie po lewej stronie wyrazenia opisujacego
przebieg (pod osig X).

Zablokowac potozenie
kursoréw

Menu Tools » Cursor » Freeze lub Ctrl+Shift+F.

Przesunac kursor do
najblizszego
charakterystycznego
punktu na aktualnym
przebiegu

Skorzystac¢ z ikonek: ¥ aby odnalez¢ najblizsze lokalne
maksimum/minimum; xelr aby odnalez¢ globalne
minimum/maksimum; #[_ aby odnalez¢ punkt o najwigkszej wartosci
pierwszej pochodnej (np. punkt przegiecia).

Przesunac kursor do

Ikonka E

nastepnego punktu Kursor przesunie si¢ do nastepnego punktu znajdujacego si¢ w wynikach
symulacji (pliku dat).
Odnalez¢ specyficzny Ikonka ﬂ Iub menu Tools » Cursor » Search Commands.

punkt na przebiegu

Wpisa¢ odpowiednia komende (zob. punkt 4) i zaakceptowac.

Przetwarzanie danych

Obliczy¢ funkcje celu
dla dowolnego
przebiegu

Ikonka E lub menu Trace » Eval Goal Function.

Dostepne zmienne sa wyswietlane na lewej liscie; na prawej liscie znajduja
sie dostepne funkgje celu (zob. punkt 3).

Ograniczy¢ zakres
danych (na osi X)
uzywanych do
obliczenia funkgji celu

Klikna¢ dwukrotnie na osi X [ub menu Plot » X Axis Settings.
W polu Use Data wybrac Restricted i wypetni¢ pola ... to ... (od ... do ...).
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Aby

Wykonaj

Wiaczyc¢/wylaczy¢
wyswietlanie wynikéw
obliczen funkgji celu na
wykresie

Menu Tools » Options, zaznaczy¢/skasowac zaznaczenie Display
Evaluation. W celu wyswietlenia wyniku obliczenia funkcji celu tworzony
jest zawsze nowy wykres.

Zastosowac
transformate Fouriera
do wyswietlanych
przebiegéw

Klikna¢ dwukrotnie na osi X, w polu Processing Options zaznaczy¢ Fourier
Iub skorzyskac z ikonki i3]

Znaczniki, napisy, rysowanie

Umiesci¢ znacznik z
wartos$ciami
wspotrzednych

Ustawic¢ kursor w zadanym punkcie i skorzystac z ikonki 2 1up menu
Tools > Label » Mark.

Skasowacé znacznik z
wartosciami
wspotrzednych

Podswietli¢ napis klikajac na nim lewym przyciskiem myszy i wcisna¢ Del.
W identyczny sposdb usuwa sie linie taczaca napis z punktem, ktérego
dotyczy.

Doda¢ dowolny napis

Ikonka E Iub menu Tools » Label » Text.

Whpisa¢ tekst, zaakceptowac i umiescic tekst w zadanym miejscu.

Zmodyfikowac napis
lub tekst znacznika z
warto$ciami
wspotrzednych

Podswietli¢ napis klikajac na nim lewym przyciskiem myszy i wybrac z
menu Edit » Modify Object.

Narysowac figure
geometryczna

Menu Tools » Label; wybra¢: Line - linia prosta, Poly-line — linia tamana,
Arrow - strzatka, Box — prostokat, Circle — okrag, Ellipse — elipsa.

Skasowac napis lub
figure geometryczna

Podswietli¢ obiekt klikajac na nim lewym przyciskiem myszy i wcisnac
Del.

Zaznaczy¢ punkty, dla
ktorych istnieja wyniki
symulacji (w pliku dat)

Ikonka >+ 1ub Menu Tools » Options, zaznaczy¢ Mark Data Points.

Umiescié na
przebiegach symbole
graficzne

Menu Tools » Options, w polu Use Symbols wybra¢ Always. (Funkcja
pomocna do odréznienia krzywych na wykresach czarno-biatych.)

Zmieni¢ tytut biezacego
okna

Menu Edit » Modify Title (spowoduje réwniez zmiane tytutu na wydruku).

Zmieni¢ tytut osi Y

Klikna¢ dwukrotnie na osi lub wybrac os jako aktualng i z menu wybrac
Plot»Y Axis Settings.

W polu Axis Title wpisa¢ zadany tekst.

Odswiezy¢ zawartos¢
biezacej strony (okna)

Menu View »Redraw [ub Ctrl+L.
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Program Probe 5

2. Funkcje arytmetyczne

Funkgji tych mozna uzywac do wpisywania wyrazen w polu Trace Expression:
* przy dodawaniu nowego przebiegu (menu Trace » Add),
* przy zmianie wyrazenia opisujacego wyswietlany przebieg (menu Edit » Modify Object),
*  przy zmianie zmiennej osi X (menu Plot»™ X Axis Settings, przycisk Axis Variable).
Role samodzielnych wyrazen lub argumentow funkcji moga petni¢:
= potencjaly weztow: V (nazwa_wezta),
* napiecia miedzy weztami: V (nazwa_wezta_dodatniego, nazwa_wezta_ujemnego),

= potengjaly koncowek elementow: Vx(nazwa_elementu) lub V (nazwa_elementu:x), gdzie
x — oznaczenie koncowki (charakterystyczne dla danego elementu, np. B - baza, D — dren itd.),

= prady elementow dwukoncowkowych: I (nazwa_elementu),

= prady koncowek elementéw wiecej niz dwukoncowkowych: Ix(nazwa_elementu), gdzie
X — oznaczenie koncowki,

* zmienna niezalezna analizy: Frequency - czestotliwo$¢ (dla analizy AC), Time — czas (dla
analizy przejsciowej),
= stale rzeczywiste,
*  wyniki czterech podstawowych dziatan arytmetycznych (+, -, *, /) wykonanych na elementach
powyzszych grup.
Stale moga by¢ podawane w formacie naukowym (np. 1.5e3) lub inzynierskim (np. 1.5m); w tym
ostatnim przypadku stosuje si¢ oznaczenia (wielkos$¢ liter jest istotna): p — piko, n — nano, u — mikro,
m - mili, K - kilo, M — mega, G - giga.

Dostepne w programie Probe funkcje arytmetyczne zebrano w ponizszej tabeli.

Oznaczenie Opis
ABS(f) Warto$¢ bezwzgledna
ARCTAN(f) Arcus tangens (wynik jest zwracany w radianach)
ATAN(f)
AVG , x
0 Srednia: AVG(/(x),x) =+ j £ (x)dx
x
0
AVGX(fa) , 1k
Srednia: AVGX(f(x), a, x) =— Jf(x)dx dlax>a,
a X—a
AVGX(f(x),x) = AVG(f(x),x) dlax <a.
COS(f) Kosinus (program zaklada, ze argument jest podany w radianach)
D(f) Pochodna po zmiennej osi X
DB(f) Wartos¢ w decybelach (20 loguo f)
ENVMIN(f,n) | Obwiednia od strony miniméw; funkcja taczy sasiednie minima lokalne, przy czym n
jest liczba punktow, w ktérych f musi mie¢ wartos¢ wieksza od wartosci w punkcie x,
aby punkt x zostat uznany za minimum lokalne
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6 Program Probe

Oznaczenie Opis
ENVMAX(f,n) | Obwiednia od strony maksiméw; funkcja faczy sasiednie maksima lokalne, przy
czym n jest liczba punktow, w ktérych f musi mie¢ warto$¢ mniejsza od wartosci w
punkcie x, aby punkt x zostat uznany za maksimum lokalne
EXP(f) Funkcja wyktadnicza
G(f) Opdznienie grupowe
IMG(f) Cze$¢ urojona przebiegu zespolonego
LOG(f) Logarytm naturalny
LOG10(f) Logarytm dziesietny
M(f) Amplituda przebiegu zespolonego
MAX(f) Warto$¢ maksymalna
MIN(f) Warto$¢ minimalna
P(f) Faza przebiegu zespolonego
PWR(f1,f2) Potega (f okresla podstawe, f2 okresla wyktadnik)
R(f) Czesc¢ rzeczywista przebiegu zespolonego
RMS(f) F
Warto$¢ éredniokwadratowa przebiegu: RMS(f(x), x) = —j 12 (x)dx
x
0
5(f) !
Catka wzgledem zmiennej osi X: S( f(x), x) = j f(x)dx
0
SGN(f) Znak (-1dlaf<0,0dlaf=0,1dlaf>0)
SIN(f) Sinus (program zaklada, ze argument jest podany w radianach)
SQRT(f) Pierwiastek kwadratowy
TAN(f) Tangens (program zaktada, ze argument jest podany w radianach)
Kilka przyktadow:
= V(2)
potencjat wezta 2
= V(mid,54)

napiecie miedzy weztem mid a weztem 4 [rownowazne V(mid) -V (4)]
= (V1(R2)-V2(R2))/2
potowa spadku napigcia na rezystorze R2
= -I(V5)
prad zrodia V5 ze zmienionym znakiem
= ID(M2)*(V(M2:D)-V(M2:95))
iloczyn pradu drenu tranzystora M2 i napiecia dren-zrédto tego tranzystora
= 1.5+5*C0S(2*3.14*50*Time)
kosinus o czestotliwosci 50 Hz, amplitudzie 5 i sktadowej stalej 1,5
= D(IC(QIN))
pochodna pradu kolektora tranzystora QIN po zmiennej osi X (zwykle — po czasie)
=  AVGX(I(C31)*V(23,24),2n)
warto$¢ srednia iloczynu pradu kondensatora C31 i napiecia wezla 23 wzgledem 24, obliczona
za przedziat zmiennej osi X o dtugosci 2-10-° (zwykle — za przedziat czasu 2 ns)
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3. Funkcje celu

Funkgji tych mozna uzywac do wpisywania wyrazen w polu Trace Expression po wywotaniu z menu

Trace®Eval Goal Function. Role argumentéw funkcji moga pelni¢ te same wyrazenia, co w

przypadku standardowych funkcji arytmetycznych (zob. punkt 2). Najwazniejsze predefiniowane
funkcje celu zostaly opisane w ponizszej tabeli.

Obliczenia sa wykonywane zawsze na catym zakresie danych wynikowych symulacji (pobieranych z
pliku dat). Dostepny zakres danych mozna ograniczy¢ zgodnie z instrukcja w punkcie 1, sekcja

,Przetwarzanie danych”.

Funkcja

Opis

YatX(f, x)

Wartos¢ przebiegu w punkcie x

YatXpct(f, x_perc)

Wartos¢ przebiegu w punkcie x odpowiadajacym x_perc procent zakresu
danych

XatNthY(f, y, n)

Wartos¢ X w n-tym punkcie takim, ze przebieg f osiaga wartosc y

XatNthYpct(f, y_perc, n)

Wartos¢ X w n-tym punkcie takim, ze przebieg f osiaga wartos¢ y_perc
procent zakresu danych

XatNthYp(f, y, n)

Wartos¢ X w n-tym punkcie takim, ze przebieg f przekracza wartos¢ y
zboczem narastajacym

XatNthYn(f, y, n) Wartos¢ X w n-tym punkcie takim, ze przebieg f przekracza warto$¢ y
zboczem opadajacym

Min(f) Najmniejsza wartos¢ w dostepnym zakresie danych

Max(f) Najwieksza wartos¢ w dostepnym zakresie danych

MINr(f, begin_x, end_x)

Najmniejsza warto$¢ w zakresie X od begin_x do end_x

MAXzx(f, begin_x, end_x)

Najwieksza wartos¢ w zakresie X od begin_x do end_x

SWINGr(f, begin_x, end_x)

Réznica pomiedzy maksymalna a minimalna wartoscia przebiegu w
zakresie X od begin_x do end_x

Overshoot(f) Oblicza procentowag wielko$¢ przeregulowania (réznicy miedzy
wartoscia maksymalna a koncowa przebiegu)

Falltime(f) Czas opadania liczony od 0,9ymax do 0,1ymax (ymax jest maksymalnag
warto$cia w calym dostepnym zakresie danych)

Risetime(f) Czas narastania liczony od 0,1ymax do 0,9ymax (ymax jest maksymalng
wartoscia w catym dostepnym zakresie danych)

GenFall(f) Czas opadania liczony od 0,9ybegin do 0,1yend (gdzie yvegin jest wartoscia
poczatkowa przebiegu, zas yend — wartoscig koncowa przebiegu)

GenRise(f) Czas narastania liczony od 0,1ybegin do 0,9yend (gdzie yvegin jest wartoScia
poczatkowa przebiegu, zas yend — wartoscia koncowa przebiegu)

Period(f) Okres przebiegu jako odleglo$¢ miedzy kolejnymi przejsciami przez
poziom 50% zakresu przy narastaniu przebiegu

Pulsewidth(f) Czas trwania impulsu jako odlegto$¢ miedzy kolejnymi przejSciami

przez poziom 50% zakresu (po raz pierwszy przy narastaniu przebiegu,
po raz drugi — przy opadaniu przebiegu)
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Funkcja Opis

Bandwidth(f, p) Szerokos¢ p-decybelowego pasma przebiegu f bedacego charakterystyka

BPBW(f, p) pasmowoprzepustowa (wartosc p nalezy podac bez sufiksu ,,db”)

HPBW(f, p) p-decybelowa czestotliwo$¢ graniczna przebiegu f bedacego
charakterystyka gornoprzepustowa (wartos¢ p nalezy podac bez sufiksu
,,db”)

LPBW(f, p) p-decybelowa  czestotliwo$¢ graniczna przebiegu f bedacego
charakterystyka dolnoprzepustowa (wartos¢ p nalezy podac bez sufiksu
. dbl/)

GainMargin(fi, f2) Margines wzmocnienia. Wyrazenie fi zawiera przebieg roznicy fazy w
stopniach; wyrazenie f» zawiera przebieg wzmocnienia w decybelach

PhaseMargin(fi, f2) Margines fazy. Wyrazenie fi zawiera przebieg wzmocnienia w

decybelach; wyrazenie f2 zawiera przebieg réznicy fazy w stopniach
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4. Komenda poszukiwania punktu

Komendy tej mozna uzy¢ do znalezienia szczegélnego punktu na przebiegu i przesuniecia kursora do
tego punktu (menu Tools » Cursor » Search Commands).

Skladnia:

search [kierunek] [/punkt_startowy/] [#liczba_punktéw#] [(xmin, xmax [, ymin, ymax])]
[for] [ktéry_punkt:] warunek

Parametry w nawiasach kwadratowych i stowo kluczowe for sa opcjonalne. Znaczenie i
dopuszczalne wartosci parametrow zawiera ponizsza tabela.

Parametr

Znaczenie, dopuszczalne wartosci

kierunek

Kierunek przeszukiwania: forward — w przod, backward — w tyt.

punkt_startowy

Punkt poczatkowy przeszukiwania: * lub begin — pierwszy punkt z zakresu; $ lub
end — ostatni punkt z zakresu. Domys$lnie przeszukiwanie zaczyna si¢ od biezacego
punktu (wskazywanego przez kursor).

liczba_punktéw

Okredla, ile kolejnych punktéw musi speinia¢ zatozenia charakterystyczne dla
danego typu parametru warunek. Domyslnie: 1.

Xmin, Xxmax,
ymin, ymax

Okreslaja zakresy wartosci (przedziaty domkniete) na osiach X i Y, w ktérych ma
by¢ wykonane przeszukiwanie. Domyslnie zostanie przeszukany caly zakres
zmiennej osi X.

Parametry te moga by¢ wyrazone w wartosciach bezwzglednych (np. 12.2n,
6.5e-9) lub w procentach zakresu osi (np. 60%). Aby ograniczy¢ tylko zakres na
osi Y, nalezy xmin i xmax pozostawi¢ puste —np. (, ,1m,2m).

ktory_punkt

Okresla, ktory z kolei punkt spetniajacy warunek ma zosta¢ wyszukany.

warunek

Okresla warunek, ktéry ma spelnia¢ punkt danych.

Parametr warunek moze by¢ zdefiniowany na jeden ze sposobdéw przedstawionych w kolejnej tabeli.
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Warunek

Skrot

Opis, parametry

level(wartos¢
[, kier_zmian])

le

Wartos¢ wspdlrzednej Y przekracza podany poziom wartosé. Jezeli
przekroczenie ma miejsce w punkcie, gdzie nie ma wynikéw symulagji,
punkt ten jest wyznaczany przez interpolacje. Co najmniej
(liczba_punktow-1) punktéw nastepujacych po znalezionym musi sie
znajdowac po tej samej stronie podanego poziomu, co znaleziony punkt.
Parametr wartos¢ moze by¢ podany w jednej z nastepujacych postaci:
* bezwzglednej —np. 100n, le3;
* procentowej (w procentach zakresu osi Y) — np. 40%;
*  wzglednej — np. min+20, .-10, max-3db (gdzie: kropka (.)
oznacza ostatnio znaleziony punkt lub punkt poczatkowy, jezeli
biezace wyszukiwanie jest pierwszym; min oznacza warto$¢

najmniejsza; max oznacza wartos¢ najwieksza; db oznacza
decybele).

Parametr kier_zmian oznacza kierunek przekroczenia poziomu: positive
(p) — z warto$ci mniejszych na wigksze, negative (n) — z wartosci
wiegkszych na mniejsze, both (b) — w dowolnym kierunku. DomySlnie:
both. Uwaga: jezeli parametr kierunek zostal okreslony jako backward, to
przy kier_zmian rébwnym positive zostanie odnalezione zbocze opadajace,
a przy negative —narastajace.

slope[(znak)]

sl

Maksymalna stromos$¢ (np. punkt przegiecia). W co najmniej liczba_punktéw
punktéw nastepujacych po znalezionym przebieg musi mie¢ nachylenie
(pierwsza pochodng) mniejsza, zerowa lub przeciwnego znaku niz w
znalezionym punkcie. Znaleziony punkt jest tworzony sztucznie w potowie
drogi miedzy dwoma punktami wyznaczajacymi maksymalna stromosc.

Parametr znak okresla znak pochodnej: positive (p) — gdy wartosci Y
wzrastaja ze wzrostem indekséw X (parametr kierunek nie ma tu znaczenia),
negative (n) — w przeciwnym wypadku, both (b) — dowolne nachylenie.
Domyslnie: both.

peak

pe

Maksimum lokalne. W co najmniej liczba_punktéw punktow po kazdej
stronie znalezionego punktu przebieg musi mie¢ warto$¢ mniejsza niz w
znalezionym punkcie.

trough

tr

Minimum lokalne. W co najmniej liczba_punktéw punktéw po kazdej stronie
znalezionego punktu przebieg musi mie¢ wartos¢ wieksza niz w
znalezionym punkcie.

Minimum globalne; jezeli istnieje wigcej punktéow, w ktérych przebieg
osiagga to samo minimum, zostanie odnaleziony pierwszy z punktéw. Na
wynik nie maja wptywu parametry: kierunek, punkt_startowy, liczba_punktéw
i ktéry_punkt.

max

Maksimum globalne; jezeli istnieje wigcej punktow, w ktorych przebieg
osigga to samo maksimum, zostanie odnaleziony pierwszy z punktéow. Na
wynik nie maja wptywu parametry: kierunek, punkt_startowy, liczba_punktéw
i ktéry_punkt.

point

po

Nastepny punkt w zbiorze danych wynikowych symulacji (pliku dat).
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Program Probe 11

Warunek Skrot | Opis, parametry

xvalue(wartosc) | xv Pierwszy punkt posiadajacy dang wartos¢ zmiennej osi X. Na wynik nie

majg wplywu parametry: kierunek, punkt_startowy, liczba_punktow, xmin,
xmax, ymin, ymax, ktéry_punkt.
Parametr wartos¢ moze by¢ podany w jednej z nastepujacych postaci:
* bezwzglednej —np. 100n, le3;
= procentowej (w procentach zakresu osi X) — np. 40%;
*  wzglednej — np. min+20, .-10, max-3db (gdzie: kropka (.)
oznacza ostatnio znaleziony punkt lub punkt poczatkowy, jezeli
biezace wyszukiwanie jest pierwszym; min oznacza warto$¢

najmniejszg; max oznacza wartos¢ najwiekszg; db oznacza
decybele).

Przyktady:

search 1le(0)

odnajdzie kolejne przejscie przebiegu przez 0, idac wzdtuz osi X w prawo

search forward 1le(0,p)

odnajdzie kolejne przejscie przebiegu przez 0 z wartosci mniejszych na wieksze, idac wzdtuz
osi X w prawo (a wiec na zboczu narastajacym)

search backward for 1le(0,p)

odnajdzie kolejne przejscie przebiegu przez 0 z wartosci mniejszych na wieksze, idac wzdiuz
osi X w lewo (a wiec na zboczu opadajacym)

search (10k,1M) le(max-3db,n)

odnajdzie najblizszy punkt polozony na prawo od aktualnego taki, ze amplituda sygnatu
bedzie o 3 dB mniejsza od maksymalnej, oraz ze charakterystyka w tym punkcie ma ujemna
pierwsza pochodnag; przeszukiwanie bedzie si¢ odbywac wylacznie w przedziale zmiennej osi
X (zwykle w takim przypadku jest to czestotliwosc) od 10* do 106

search #3# for 4: pe

odnajdzie 4. z kolei maksimum lokalne potoZzone na prawo od aktualnego punktu, przy czym
za maksimum zostanie uznany punkt, po ktérego kazdej stronie beda co najmniej 3 punkty, w
ktérych przebieg ma warto$¢ mniejsza od wartosci w tym punkcie

search backward /end/ 2: tr

odnajdzie 2. z kolei minimum lokalne potozone na lewo od konca zakresu osi X, przy czym za
minimum zostanie uznany punkt, po ktoérego kazdej stronie bedzie 1 punkt, w ktérym
przebieg ma wartos¢ wieksza od wartosci w tym punkcie

search (@,5k) max

odnajdzie punkt o maksymalnej wartosci w przedziale zmiennej osi X do 0 do 5-10° (wlacznie
z01i5)

search xvalue(50%)

odnajdzie punkt znajdujacy si¢ w potowie zakresu osi X
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